El repositorio Backports de Debian: USE CON CUIDADADO.

Nota posterior a la publicación: Un tiempo después volví a actualizar Libreoffice siguiendo el procedimiento que descrito y no hubo nigún problema; la incompatibilidad que describo estaba ya subsanada. Actualmente está ya disponible en Backports la versión 4.1.0.4 de Libreoffice.

Sobre Backports

El repositorio Backports en la rama estable de Debian (Wheezy actualmente) proporciona paquetes para nuevas versiones de determinadas aplicaciones que se van incluyendo a lo largo del periodo de vida de la versión. Sin embargo desde el sitio oficial (http://backports.debian.org/Instructions/) recomiendan utilizar este repositorio con precaución ya que en ocasiones pueden existir incompatibilidades de dependencias entre estos paquetes y los estables. Los paquetes que van formando parte de Backports proceden mayoritariamente de la rama “testing” y “unstable” y pueden funcionar en la “stable” sin nuevas librerías, pero es sí: siempre que sea posible. Como también indican en la página oficial, estos paquetes no han sido probados tan extensamente como los de Debian estable y existen riesgos de incompatibilidades. Y aclaran: USE CON CUIDADO. No obstante, en determinados casos nos pueden ser muy útiles.

Para añadir el repositorio hay que agregar la siguiente linea a nuestro archivo sources.list, editando en consola el archivo como root:

# nano /etc/apt/sources.list

deb http://YOURMIRROR.debian.org/debian wheezy-backports main

En mi caso YOURMIRROR para este repositorio es: ftp.debian.org y por tanto el repositorio queda así:

deb http://ftp.debian.org/debian wheezy-backports main

Después:

# apt-get update

O también podemos añadir el repositorio mediante Synaptic: Configuración> Repositorios> Add. Y después en la ventana principal “Recargar”.

Una vez hecho esto podemos actualizar o instalar programas desde este repositorio pero siempre de forma específica. De hecho -y como medida preventiva- los paquetes de Backports están deshabilitados por defecto y no se instalan ni se actualizan con “apt-get install” o “apt-get upgrade” sino que para instalar o actualizar hay que utilizar la siguiente línea de comandos:

# apt-get -t wheezy-backports install nombre_programa

Un ejemplo de incompatibilidades

Esta ya disponible en Backports Libreoffice 4.0.3.2, e impulsado por mi tendencia “actualizadora” opté por instalar la nueva versión siguiendo el procedimiento anterior en mi Debian Wheezy con escritorio KDE.

# apt-get -t wheezy-backports install libreoffice libreoffice-l10n-es

Pero mi “gozo en un pozo”, al terminar la instalación me lanzó un mensaje de error por problemas de dependencias: “se encontraron errores al procesar libreoffice-style-oxygen”. Los paquetes requeridos para esta versión (4.0.3.2) no estaban disponibles, concretamente: libreoffice-style-oxygen y libreoffice-core que están en la versión estable. En definitiva, al abrir el editor de texto o cualquier otra aplicación da error; no funciona. Pero esto no me pillo por sorpresa, entraba dentro de lo probable. Es posible que si deshabilito la integración de las aplicaciones GTK en KDE pueda solucionar el problema, pero, hoy por hoy, prefiero disponer de esta funcionalidad y no de una versión superior de Libreoffice que en principio no aporta nada destacable a mi trabajo rutinario. Si fuera otra la situación, pues quizás actuaría de otra forma. Así que deshice el entuerto siguiendo las instrucciones que me lanzo la terminal, y que le pueden ser útiles a alguien que le haya sucedido esto mismo:

# apt-get update

# apt-get upgrade

Nos da la siguiente instrucción:

# apt-get -f install

# apt-get autoremove

Y ya que estamos de limpieza

# apt-get clean

Con lo que desinstalamos la versión 4.0.3.2, paquetes que se instalaron de forma automática y limpiamos la cache. Para retornar a la versión estable de Libreoffice (3.5.4.2):

# apt-get install libreoffice lifreoffice l10n-es

En fin, como dicen en mi tierra “simplemente una mata que no dio fruto”, pero no por ello Debian deja de ser un magnifico SO, sólido como una roca. Para tener aplicaciones más actualizadas existe también la posibilidad de utilizar la rama testing (Jessie); en el pasado me resulto una opción muy adecuada y recomendable. Pero para mi aún es pronto, por el momento yo estable.

Deja un comentario

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios.

10 ideas sobre “El repositorio Backports de Debian: USE CON CUIDADADO.”

A %d blogueros les gusta esto: